Features / Usability

Features / Usability

Website upgrade from TikiWiki 12.2 to 15 : JavaScript error and Search functionality error

posts: 12 Australia

Hi there
Hoping you can assist. First time user, so please bear with me.
I have a website called www.tigerlandarchive.org
My server guy just upgraded the site from 12.2 TikiWiki to 15 TikiWiki.
All went well apart from 2 errors.
I'm hoping someone could assist.

1. If you go my website, you'll see a Java Script error on each page you click on.
"A problem occurred while detecting JavaScript on this page, click ok to retry''
By clicking okay, the next page loads fine. But that pop up is pretty annoying.
Is it something I need to alter from my admin login at the console ? Or is it from my server guy

2. The Search functionality no longer works.
The Search option is there on the left, but if you go to it and type in any keyword search (ie: Crowe, Brunswick, Football, Tribunal) no results surface.
In my admin console under General Settings and Search I have Unified Search Index pre-ticked. But there is an exclamation point next to it that indicates: 'Warning: Unified Search Index requires server process resources'. Is that something to do with the Search issue.?
There is also a Rebuild Index button that when I click on brings up a large page saying 'Your index was last fully rebuilt on Sunday October 19 2014.
Is this Search issue something I could fix in my admin , or again is it from my server guy.

Sorry to both you all
Kind Regards


posts: 956

HI Rhett:

I did a quick visit with Chromium, and your site loads with no javascript error (I'm not looking at developer console or something, just as if I am and end user visiting your page).

And search results returned some match for me. I searched for Football, and it returned the page: War

I hope this helps.

g'day and Welcome to the Tiki Community! smile

posts: 12 Australia

Hey Xavi
G'day to you. Thank you for the reply.

Can I ask a follow up. You were saying no javascript error loads for you when simply browsing the site as end user. Are you able to just click on a few links on the main page (say "Player Bios", "Richmond Hall of Fame", or "1911" ) and tell me if the script pops up. Cause I still get the pop up on pages, but want to eliminate my browser as the possible cause (I am using Chrome, and just cleared the cache).

As well, with the search, are you able to try other words that should populate like 'Tribunal', 'Crowe', 'Backhouse'. It appears only a handful of pages are indexing under Search.

Hope this isn't an inconvenience for you.


posts: 2695 United States

I visited with WinDoze 10 Chrome browser.
I get the JavaScript popup when I visit a bio.

I tried searching for tribunal

  • got a javascript error popu
  • no results found

crowe = no results
Backhouse = no results

I bet you need to rebuild your index.

  • That is something you can do as admin.
    • I had some strange problems awhile back on my website and doing this cured the problem.


posts: 12 Australia

Thanks Wizar
When I log in as admin, and click on Search module, there is a big Rebuild Index button.
If I click on that it says my last rebuild was October 2014.
But then I don't see how I can actually *start* the rebuild
(There's only some Info buttons about 'Indexing Problems, Command Line Utilities')

Any thoughts ?

I'm assuming the JavaScript popup I get is separate from the Search issue.
I'm still not sure how to remove the JS popup


posts: 12 Australia

Hey WizarDave

Yep I see a large button that says Rebuild Index, which I press and a large pop up appears saying
"Your Index was last fully rebuilt on Sunday October 19 2014.
Enable Logging (with a tickbox next to it)
Then two large boxes saying Indexing Problems ? and Command Line Utilities?

That's all.

posts: 12 Australia

All fixed
I posted in the Installation forum and a user was able to screenshot the errors that were coming up, which was Server guy was able to fix
By fixing that, it also allowed me to index my search.

all issues resolved
Thank you all for your assistance