Import HTML parsed pages into the wiki

posts: 15


we want to import our wiki, which are around 6250 html files, into the tiki wiki.

I already wrote a parser, which creates an sql file . We are even able to import the pages into the tikiwiki, but, we are not able to "visiti" the pages.

All of the pages are listed in "tiki wiki -> admin -> content -> pages" and editable, with the whole content. But when you want to look at a page, tiki wiki says that the page is missing.

What entrys are we missing, so we can view the pages?

posts: 1563 Germany

Might be some missing parameter (sql-table-cell).

Importing to the Tiki DB is good, but did you consider Id numbers?

In Tiki every content element, maybe every element at all has an Id number, for ex. a tracker has an Id, a tracker item has an Id, an article has an Id and even wiki pages wich are usually not used with their Ids have Id numbers.

Once you found that your wiki pages have Id numbers, you should check in the database if there is a table which maps wiki page Ids somehow.

Example with trackers or blogs: each tracker item orblogpost gets an incrementally upcounted Id number independantly to which tracker or blog  it belongs. There is a table for the tracker feature and a table for the blog feature to map which item / post belongs to which tracker / blog.

Maybe there is something similar with wiki pages, which would possibly explain the issue.

Sorry, that I cannot help more at this point, but maybe the above helps to direct you to the right spot. Hopefully.



posts: 15

Thans for the reply!

I found my problem. What I did was, I deleted the whole wiki incl. database and reinstalled everything. Then I made a new tiki site and compared the database. The only relevant change was in "tiki_pages". Than i imported a single page with "INSERT INTO 'tiki_pages'('pageName', 'pageSlug', 'data', 'is_html') VALUES ('Test', 'TestSite', '


', 1) " and this worked too.

So I was able to call the site via the "pageSlug". Than I imported a test file from our old website and it didn't worked.

The problem was simply... there was a space before and after the pageSlug, so I didn't had "test" but " test ", and that is not a valid URL.

I changed my tool for the export, created new SQL files and now everything works fine! Thank you really much.