Architecture / Installation

Architecture / Installation

Unable to read template file 'layout_view.tpl'

posts: 3 United Kingdom

I've just upgraded a v12 tikiwiki to v14. I unpacked the v14 files into a clean folder, and ran the installer to upgrade the database. It had 7 issues, but nothing serious.

As soon as the installer finished though, tikiwiki now only responds with 500 errors. The PHP log states:

PHP Fatal error: Uncaught --> Smarty: Unable to read template file 'layout_view.tpl'

posts: 3 United Kingdom

Also, the forum decided to just delete most of my post after a greater-than sign.

Running ProcMon i can see it's searching for:


But the only files that exist are:


I have tried manually editing the 'style' and 'theme' rows in the preference table to 'basic' and 'classic' (and clearing out the cache) but nothing works.

posts: 126886 United Kingdom

Hi Trekker

That sounds bad. The pref related to this is called "site_layout" and the default value for it is "basic" - deleting that row if present will revert it to the default.

You'll probably then have to clear all the caches afterwards which you can do from the command line using:

Copy to clipboard
php console.php cache:clear --all

Mind you, those layout files live in templates/layouts as you found, so i'm not sure why it's not checking in there at all, no matter what the site_layout is set to... maybe there is a fault in 14.0 for your particular case, so perhaps try one of the recent daily tarball builds? We're close to releasing 14.1 so maybe something was fixed in the mean time?

Hope that helps, maybe join us on IRC for some more interactive help?


posts: 3 United Kingdom

Thank you for the help - removing that setting has got it partially working!


I've now got the login form, but I can't log in. If I enter an wrong username, or a right username with wrong password, the I get "Invalid username or password" as expected. If the password is right though,  it dies again with a 500 error. This time with no error in the php log, or Windows event viewer.


We're using LDAP, and it seems to be to do with that. Looking at the syslog, it dies after 'UsersLib

ldap_sync_user_data()' or 'UsersLib


We had to set up some wierd stuff to get LDAP working - because the web server is external to our network, I had to add a fake hosts entry to point e.g. domaincontroller.company.local to our office's external IP.

I'll sprinkle some var_dumps around and see exactly where it is dying.


EDIT: This is a wierd rabbit hole of issues.

I've fixed LDAP - this was due a crazy bug where UserLib is trying to call a function that doesnt exist (ldap_sync_groups instead of _ldap_sync_groups). Changed the code and I can now log in, but the page elements are all over the place. In fact, tikiwiki is not including any JavaScript what-so-ever.

This must be an issue with the $headerlib bit at the bottom of footer.tpl. I will get this working if it kills me!

posts: 9 Netherlands

To inform: I have the same problem.

I upgrade from 12 to 14 and got the same message

The above information is to complicated for me as no expert

My cache is clear and as far as I know i have delete the row in the database within preferences about  "site_layout".


posts: 9 Netherlands

It works now;

I did the installation one more time and went trough the upgradeprocess for the database after the upload of the files; after that it worked this time.

Probalbly because of the stepts from yesterday as combination with these steps.