Loading...
 
Architecture / Installation

Architecture / Installation


Can't view or add tracker fields after fresh new install

posts: 1 Chile

Hello there. I'm new to the community and I've been using Tiki for a month already. Documentation is alright although lacking some times, but I tend to find a workaround for everything anyway.
However, this is an issue I seem unable to fix by myself.

I'm going straight to the point now.

I had 12.9 running for quite a while, with a few trackers, some wiki templates to show their items, some wiki pages; you get it. That, until I realized that using Items Lists fields in a certain tracker wouldn't link me to the separate items => They were comma-separated values. I figured I could make a script to divide it into a list.
I thought this was a feature only lacking in 12.9, so I decided to upgrade to 15.2, which pretty much screwed up my whole setup... While I still have everything in order, I couldn't even work with Item Links or Item Lists anymore; they wouldn't show up any options to choose to link to (or from). I'm not exactly sure how this came to be, since I followed every step in the Upgrading guide and I don't have a complex system, either.

Well, well. I did backup both my tiki folder and my tiki database. Restored them, everything back to 12.9. Now, while I do have my items... I can't view the fields they use, and the Add Field button doesn't work. It simply doesn't do anything.

btw all databases were and are working under InnoDB and utf8_unicode_ci

Tried starting a fresh, brand-new, out-of-the-box, etc, database and setup in general, loaded the Community Collab profile or whatever is called, that one with the calendar using a tracker. This, to make sure my database wasn't the problem... Yet I still have the same issue; while I can see the items in the tracker, I can't view or add new fields; they simply don't show up. Everything else works fine, but this is the feature I need the most. I hope you guys can help me understand why this happens, I might be able to fix it myself but I don't even know where to start searching.



EDIT: In the end I couldn't afford the time to wait for an answer, so I simply used the internal Tiki export/import features to backup the important stuff, deleted EVERYTHING and now it works. In 12.9 because I can't figure out how to use pretty trackers in 15.2 -the templates I made don't work :c

There are no comments at this time.

Upcoming Events

1)  25 Jun 2024 16:00 GMT-0000
Data umbrella : Build Your First Database Web App with (open source) Tiki Trackers
2)  18 Jul 2024 14:00 GMT-0000
Tiki Roundtable Meeting
3)  15 Aug 2024 14:00 GMT-0000
Tiki Roundtable Meeting
4)  19 Sep 2024 14:00 GMT-0000
Tiki Roundtable Meeting
5) 
Tiki birthday
6)  17 Oct 2024 14:00 GMT-0000
Tiki Roundtable Meeting
7)  21 Nov 2024 14:00 GMT-0000
Tiki Roundtable Meeting
8)  19 Dec 2024 14:00 GMT-0000
Tiki Roundtable Meeting