Loading...
 
Français

Français


[RESOLU] LDAP en 6.2, 7.x et 3.8

posts: 9

Bonjour,

J'ai des soucis avec le LDAP. Le résultat est différent selon la version de tiki que j'utilise : avec 3.8 LTS, toujours password invalide, avec 6.2, page blanche, et avec 7.x ca marche impec
tout ca sur le même environnement (ubuntu 10.04, apache 2.2.14, mysql 5.1.41, php 5.3.2)

Si quelqu'un pouvait me dire vers où chercher ...

merci d'avance

AntoineN

posts: 1001 Canada

Bonjour,
les pages blanches sont généralement causées par des erreurs HTTP 500 provenant d'erreurs PHP fatales lorsque l'affichage des erreurs et désactivé. Vérifiez les valeurs des options reliées display_errors et error_reporting et essayez d'appliquer le profil Debug Mode Enabled.

En passant, le canal IRC #tikiwiki sur freenode est ouvert si vous pouvez vous exprimer en anglais.

posts: 9
Philippe Cloutier wrote:

Bonjour,
les pages blanches sont généralement causées par des erreurs HTTP 500 provenant d'erreurs PHP fatales lorsque l'affichage des erreurs et désactivé. Vérifiez les valeurs des options reliées display_errors et error_reporting et essayez d'appliquer le profil Debug Mode Enabled.

En passant, le canal IRC #tikiwiki sur freenode est ouvert si vous pouvez vous exprimer en anglais.


Merci pour l'info.
Page blanche sur LDAP2::connect de lib/auth/ldap.php. J'ai essayé de debugger plus loin, mais ma capacité est limitée ...

Vu que ca fonctionne (authentification par LDAP) avec la 7.x, j'ai remplacé dans la 6.2 les répertoires lib/auth et lib/pear par ceux de la 7.x, et ca marche en 6.2
Il y aura probablement des dégâts collatéraux, mais pour l'instant, je n'en ai pas vu.

posts: 1001 Canada
Ce qui aiderait vraiment est de voir le message d'erreur PHP. Avez-vous appliqué le profil Debug Mode Enabled? Ou regardé les préférences de débogage dans le panneau d'administration Général?
posts: 9
Philippe Cloutier wrote:
Ce qui aiderait vraiment est de voir le message d'erreur PHP. Avez-vous appliqué le profil Debug Mode Enabled? Ou regardé les préférences de débogage dans le panneau d'administration Général?


J'ai vu que le profil debug_mode_enabled n'était pas accessible pour une 6.x, donc pas utilisé. Dans le panneau administration, j'avais bien "toutes les erreurs PHP". J'avais aussi mis des traces (echo) dans LDAP.php, potassé les docs LDAP2, mis debug de l'array de connexion à true... c'est là que mes compétences en la matière s'arrêtent.


posts: 1001 Canada
Avez-vous vérifié les options PHP? Activez display_errors et redémarrez Apache.
posts: 9
Philippe Cloutier wrote:
Avez-vous vérifié les options PHP? Activez display_errors et redémarrez Apache.


oui.


posts: 1001 Canada

Vous pouvez utiliser le profil Debug_Mode_Enabled avec Tiki 6.
Avec la configuration appropriée, vous ne devriez pas obtenir de page blanche.
Si vous n'arrivez toujours pas à faire afficher l'erreur, joignez votre fichier php.ini et la sortie de phpinfo.

posts: 9
Philippe Cloutier wrote:

Vous pouvez utiliser le profil Debug_Mode_Enabled avec Tiki 6.
Avec la configuration appropriée, vous ne devriez pas obtenir de page blanche.
Si vous n'arrivez toujours pas à faire afficher l'erreur, joignez votre fichier php.ini et la sortie de phpinfo.


Exact. Voici l'erreur :
Fatal error: Call to undefined method PEAR_Error::getValue() in /disk2/test/lib/pear/Net/LDAP2.php on line 1159

et la ligne 1159
$supported_versions = $rootDSE->getValue('supportedLDAPVersion');

Quelle serait la suite des opérations ??

Merci pour l'aide


posts: 9
Philippe Cloutier wrote:
Philippe Cloutier wrote:

Cette erreur doit avoir disparu après http://tikiwiki.svn.sourceforge.net/viewvc/tikiwiki?view=revision&revision=29906

Rétroporter cette modification dans la branche 6 devrait régler le problème pour 6.2.


Effectivement, j'ai récupéré la révision et tout est rentré dans l'ordre.

Merci ++


J'ai parlé un peu vite ..
Il reste quand même : Fatal error: Call to a member function getEntry() on a non-object in /disk2/test/lib/auth/ldap.php on line 258

...


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.