Loading...
 

ReleaseNotes172

Released on October 1st, 2003

Release process

Released on October 1st, 2003 

  • ReleaseNotes172

Warning !

The following notes are kept for archive only, and should not be modified (unless there is something missing from the changelog).

1.7.2 bugfix release process 


The branch release_eta_carinea_rc1 (so badly named redface) is now the CVS branch for 1.7.x. Note that the 1.7.x branch is strictly for bugfixes. All new features and changes must be committed to CVS HEAD and not the release_eta_carinea_rc1 branch. Fixes committed to the 1.7.x branch will be merged into HEAD if not there yet.

When fixing bugs, fix the bug on release_eta_carinea_rc1 then, if you run a local copy of CVS HEAD too, it's prefered when you make the related code change (bugfix) for HEAD as well and you can add "NO MERGE NEEDED" note to your log. Otherwise just merge with HEAD. Follow the instructions at the bottom of TikiCVSTags to merge.

Developers, please update this page whenever you resolve a bug in this branch. If you need help with CVS, read Cvs17.

If you are not a developer but would like to help test the latest 1.7.2 code, download the following archive, updated every 8 hours from CVS:
http://tikiwiki.org/lastiki17.tar.bz2

Scheduled release date
The scheduled release date for 1.7.2. is October 1st, 2003. It will be conducted by luci with the help of the community.

Unresolved bugs or misbehavior 

(italicized items probably will not be addressed in 1.7.2; that doesn't mean you cannot tackle them though)

  • one sometimes (rarely) sees modules and module links that belong to another user viewing the site at the same moment
  • changes to modules and admin settings sometimes require a page reload to appear
  • left/center column sometimes takes up width of the screen: it occurs randomly
  • the quiz feature may exhibit strange behaviour
  • the chatroom sometimes causes browser to continue to refresh even after leaving
  • the site search function may give errors with Chinese or other Asian characters - fixed? (unconfirmed, who fixed this?)
  • the "Go Back" link on error pages sometimes fails in IE (after a POST or GET to same file)
  • various theme problems with different browsers
  • tiki-user cookie logs user into all Tiki sites running under the same domain if user has same username/password
  • installer does not take into account PHP safe_mode <-- can this be done? ini_get() doesn't seem to get the safe_mode value
  • Tiki running in Windows (and specifically IIS?) generate links that have an erroneous "/" before the URL parameter: ex. tiki-browse_image.php/?imageId=2
  • comment hash is title+content, making it impossible to post 2 comments with the same title and content, an uncommon but certainly possible and legitimate situation (which happened to me, luci ;))
  • numerous IIS problems; should make use of these workarounds: IisWorkarounds
  • various occurrences of "page 1/0" (harmless)
  • Category: two object types have the same name
  • wiki plugins (e.g. {BOX}, {SPLIT}) do ignore "end of line" character in the content and do not convert it to "
    " (cause displaying the block of text on one line)
  • Please see Source Forge for more possible bugs

Resolved bugs and misbehavior since 1.7.1(.1)