Loading...
 
Features / Usability

Features / Usability


Minichat module failing to refresh

posts: 43 United States

We got the minichat module working on our TW 2.0 installation, except that it's not refreshing. Another user and I were testing it out, and after the first exchange, new entries from one user were not showing up in the other user's chat window. Only after the other user did a page refresh were the new chat entries visible. (Yes, we were in the same channel.)

This was observable both when the module was in a side column, and when it was embedded in a page. (Not both simultaneously - that doesn't work in the current released version.)

Parameters were as follows:

{MODULE(module=>minichat,rows=30,channels="#default,#wikihelp")}{MODULE}


Possible causes?


Thx,
))MacLeod((

posts: 4642 Japan

Hmm, I can't seem to kill it with a stick (so to speak). Minichat refreshes at my site about every three seconds. I turned off Ajax and Mootools and cleared the caches, just to check, and the refreshes continue.

-- Gary


posts: 289 United States
What did you do to get it "working"? Modify code?
posts: 43 United States
Darren wrote:
What did you do to get it "working"? Modify code?


The original problem was that it wasn't enabled in the database, and there's no admin GUI in v2.0 to turn it on. So on the recommendation from the helpful folks in #tikiwiki, I had our contractors handling the back-end execute:

INSERT INTO 'tiki_preferences' ('name','value') VALUES('feature_minichat','y');

That at least got it running. More to follow on the additional tests of the refresh failures...

- ))MacLeod((

posts: 289 United States

Sweet, that did the trick, thanks.

Now I can do some testing of my own.