Architecture / Installation

Architecture / Installation

Help Needed

posts: 6 Cyprus

Hi All,

Installed tiki 2 no problems. Here's the bad news. Whlst going through the menu options of communities and so on I at last got to to the last option Banners - I looked at the page options and changed nothing - BUT I did click on activate - submit - the bad news is I just have a gray page and a logo link in top left hand corner - even worse is if you click on any link that's all you get and even worse if you log out - you are doomed! There's only the gray screen of death! take a look at gbenet.com and no way to get back in!!!!!!!!

Do I have to upload and start over again?

I am not happy!!

Help appreciated


David (I must be mad)

posts: 1817 Catalan Countries

Hi captaindc (David) and welcome to Tikiwiki Community smile

Make a backup of your database first.

Try going to your mysql database through phpmyadmin or similar, and search at your tiki_preferences table
Try to find there any reference to the features you enabled and options you set, etc., that you think that they might be responsible of that behavior, and change them (or remove them) from the tiki_preferences table.

And after you fix the problem, please, fill in a bug report with your problem and how you solved that, so that a coder can improve Tikiwiki performance to avoid this behavior to happen in next releases.


posts: 6 Cyprus


I picked up the email reply and decided to look at the data base (downloaded a copy in case I screwed it up). My first thought was to check the banners and flushed the content relaunched the site and got the gray wall of doom :-)

Hmmm. Ok what I need to know are default values. It's going to be a combination of entries that triggers something unexpected. Considering I'd only installed the data base a week and then a week later today (this morning) decided to use the instal-php. Everything seemed fine until I looked at the banner settings - which was the last thing I did.

The data base must get populated (perhaps) with initial values - or not? or perhaps nothing till you select save on the option menu scripts? Plainly picking one option by placing a tick in one box and in addion to clicking on activation tabs - or perhaps a sequence of ticks on other sections (site options) produces a gray screen with just a link to a logo on it.

Lucky I have another linux desktop and laptop to play with - I laugh because I will have to set up a linux server php and all and run it on a server to replicate. Thinking you have a sequence is not much use if you cant test it.

Ok, having had a coffee I need another. A few sips later and a rollup. I will put together an apache server (suse 11) with all i need and tikiwiki at least I can play with that. As I have a learning curve (fast) with tikiwiki it may be possible to replicate other issues - if that is the support network is good here - it's a brain ache working on your own! I will need a bit of time to install the whole thing so no quick solution.

Here's a question: Let's suppose I deleted my data base and then recreated it and then run the setup php again. Has any one done this? I am sure some one has - what happened? I have a bad feeling on this one :-)

I'm happy as I have time to test and look at bugs and server-side issues - also a working on-line tikiwiki is my primary goal to that end we all need help at some time.

Comments sugestions welcome. I'll back later tonight and tomorrow



posts: 6 Cyprus

Not a smart move to delete the data base.

Having said that I reinstalled from the start and now have a reasonable tikiwiki.

I say reasonable - I looked at the php requirements as the little icons fail to load or even the logo which I set to http://gbenet.com/img etc which failed to load - i set max-execution=30 max-input=60 and mem-limit=128M which is the max anyway. Version 2 of tikiwiki does not display any icons or images at all.

I thought it a browser issue - we use Firefox on a Microsoft laptop and Suse 11 on laptop and server same result no icons no logo a real pain. I can see all the little smilies to add to this post but not one single icon of any kind show up in version 2 of tikiwiki. we have apache 2 server php 5 on linux - or are we supposed to run tikiwiki on a Microsoft OS? If that's the option then I will dump this stuff of our server.

Upcoming Events

No records to display