Loading...
 
Architecture / Installation

Architecture / Installation


How does anonymous navigate to wiki for read only

posts: 16 England

Publicview
An unregistered newcomer has permission to view wiki, but I cannot see any documentation that shows me how to enable them to navigate to wiki docs, such as system menu which is available once logged in

posts: 733 United States
Hey Bill, is your goal to make anonymous able to see system menu without being logged in?
posts: 16 England
John Morris wrote:
Hey Bill, is your goal to make anonymous able to see system menu without being logged in?


Yes, or any other method that would make the wiki available read only to anyone not logged in. Like visiting wikipedia in effect.

posts: 733 United States
Bill Hopkinson wrote:
Yes, or any other method that would make the wiki available read only to anyone not logged in. Like visiting wikipedia in effect.

See my reply below.


posts: 733 United States
Go to Modules, then assign permissions for anonymous to see the module the menu is in if you want anonymous to view your menus without being logged in.

posts: 16 England

Visitor
I have created a special cut-down menu on landing page seen only by visitors who are not signed or registered. See the view above.
Now I need to edit it, but cannot find it!
I have searched modules in vain, and of course, it does not appear in Admin view. Any ideas what to do?

posts: 8422 Israel
Bill Hopkinson wrote:

Visitor
I have created a special cut-down menu on landing page seen only by visitors who are not signed or registered. See the view above.
Now I need to edit it, but cannot find it!
I have searched modules in vain, and of course, it does not appear in Admin view. Any ideas what to do?


Hello,

Did you check: Settings => Menus ? (tiki-admin_menus.php)

posts: 16 England

{QUOTE(thread_id=>77192)}Hello,

Did you check: Settings => Menus ? (tiki-admin_menus.php)

If I click on Settings in my left hand Admin menu, then Menus is not shown as an option.
If I go into Modules and look at Menus, then the left hand menu permissions all look correct, different for admin, registered and anonymous. Those show up correctly when logged in as admin, and correctly with smaller menu for registered. There is a menu shows up for not logged in, but it is faulty in that List of Wiki Pages shows with a down arrow and links to Forums. Perhaps I created a faulty duplicate? This faulty duplicate does not show up if I go into Modules. At the same time, I can see no reason why the regular left hand module does not show with the anonymous permissions as set.

posts: 8422 Israel
{QUOTE(thread_id=>77193)}
Bernard Sfez / Tiki Specialist wrote:
If I click on Settings in my left hand Admin menu, then Menus is not shown as an option.


Do you have in your module a module for the "Menu" Id=42 ?

Menu 42 is the "Master" menu and that’s why it is not modifiable.
It is there you will find admins tools and you should always keep somewhere.
(I usually have it at the bottom for the Admins group only)

You can also use the direct URL way: https://yourdomain.com/tiki-admin_menus.php

posts: 16 England

Yes, I have Menu 42, both at the bottom of Admins and direct URL.
However, I cannot examine it, presumably because it is a master menu. I can either clone it or reset it. So, should I clone it and replace the latest menu 46 which is the menu which is correct for admin and registered, but another menu which I cannot trace shows for anonymous?

Bernard Sfez / Tiki Specialist wrote:

Do you have in your module a module for the "Menu" Id=42 ?

Menu 42 is the "Master" menu and that’s why it is not modifiable.
It is there you will find admins tools and you should always keep somewhere.
(I usually have it at the bottom for the Admins group only)

You can also use the direct URL way: https://yourdomain.com/tiki-admin_menus.php

posts: 8422 Israel
Bill Hopkinson wrote:

Yes, I have Menu 42, both at the bottom of Admins and direct URL.
However, I cannot examine it, presumably because it is a master menu. I can either clone it or reset it.


... Something is wrong in your Tiki or in your explanations.
Contact me and I’ll help you to find you the answer. ;-)